【解消済み】特定条件下で継続決済の次回決済が自動実行されない不具合について
いつもコングラントをご利用くださり誠にありがとうございます。
このたび、継続決済機能において、特定の条件下で次回決済が自動的に行われない不具合が発生しました。この問題により、一部のサポーターの継続寄付が正常に処理されない状態が発生しておりました。この度は多大なご迷惑をおかけしましたことを深くお詫び申し上げます。
影響を受けた団体につきましては、該当する寄付者および寄付金額の詳細を、12月2日付でメールにてご報告いたしました。
■障害発生期間
2025年2月13日〜2025年10月28日
■障害内容
継続決済が一度失敗し、その後1ヶ月以上経過した後に再決済が成功した場合、システムが次回の決済日を過去の日付に設定してしまう問題が発生しました。このため、再決済後の次回決済が自動的に実行されず、継続寄付が一時的に停止してしまう状況が生じました。
■障害範囲
- 影響を受けた団体数:27団体
- 影響を受けた継続契約数:41件
影響を受けた団体におかれましては、影響を受けた寄付者および寄付金額を別途メールにてご報告させていただきます。
■発生原因
2025年2月に実施した継続決済機能のリニューアルにおいて、以前は自動的に解約処理されていた特定条件の継続契約が解約されず残り続けるようになりました。この仕様変更により、次回決済日の設定ロジックに不具合が生じ、特定の条件下で次回決済日が過去の日付に設定されてしまうケースが発生しました。
■対応・再発防止策
システムの改修
10月28日に根本的なシステム修正を完了しました。具体的には、継続決済の次回決済日の設定ロジックを改善し、システムが過去の日付を設定しようとした場合に自動的に未来の日付に調整するよう変更しました。これにより、どのような状況でも次回決済日が必ず未来の日付になるため、同様の問題が再発することはありません。
その他対策
本事象とは異なる原因で決済サイクル異常が発生した際に、すぐに問題の発見・調査ができるよう、社内検知システムの開発に取り組みます。社内検知システムは2025年12月中に開発完了予定となっております。
ご報告は以上となります。
この度はシステムの不具合によりご迷惑をおかけし、誠に申し訳ございませんでした。今後はより一層のシステム品質向上に努めます。